Troubleshooting steps for resolving issues when the RFID Communication Server cannot communicate with an RFID Reader
Common Causes
- Network connectivity issues
- Settings for reader not configured properly
- Hardware issue on reader
Environment / Applies To
- RFID Communication Server
Solution Summary
The RFID Communication Server will log any errors when trying to connect to RFID readers.
Note: If the RFID Communication Server is unable to connect to an RFID reader, the application will report the details of any errors it encounters in the RfidCommunicationsServerAlarmHistory.txt log file located in the application's install directory.
Connection attempts and success/failure will also be logged in the RfidCommunicationsServerConnectionStatusActivity.txt log file in the same directory.
Note: Since the application uses libraries supplied from each manufacturer to communicate, the error provided may not specifically define the source of the error.
For example, if the Alien reader is having issues with an antenna, the error that is logged during the connection to the reader is Error: OpenRFIDReader: startIndex cannot be larger than length of string. Parameter name: startIndex.
Troubleshooting steps
Verify that the RFID reader is connected to the network and powered on
Additionally, the Windows ping utility can be used to verify that the computer is able to establish basic communication with the RFID reader by pinging the IP address assigned to the RFID reader.
Verify configuration settings
Use the RFID Communication Service Configuration to verify that the reader is configured properly.
- Verify that the correct RFID reader model is selected.
- Verify that the correct IP address is specified.
- Verify that the correct TCP port for the reader is specified.
Tip: Typically the TCP port should be specified as the default port, unless the reader is being accessed through a router.
- Alien readers use port 23 by default
- Impinj readers use port 5084 by default
- Intermec (IF2) readers use port 2188 by default
Check reader to determine if there may be a hardware issue
Accessing the RFID reader's hosted web page may give an indication if there are any hardware issues with the reader.
The most common hardware issue encountered is that the reader does not recognize that an antenna is connected to the reader.
Models vary as to how they report this information. For example, the Intermec reader has an LED indicator on the physical reader that displays if there is a successful connection to an antenna. The Alien reader has an Antenna menu option available to check the status.
If the reader does not report that there is an antenna connected or is reporting any other error, remove power from the reader, wait 15 seconds after all LED indicators go out, then re-apply power. After the reader finishes starting up (this may take up to 2 minutes, depending on the reader model), check the status again.
If the issue is that an antenna is still not connected, check the cable, antenna, and connections for any damage or other visible indications.
Tip: Restarting the reader from the web page may not resolve some issues encountered with the reader. This is why it is recommended to physically remove power from the reader instead of the "soft" restart provided on the reader's web page.
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