An interface with a third-party system may fail to import an order if the order references a product that is not recognized.
Last Updated: 3/4/2021
Common Causes
- A new product is included on an order that has not been configured
- A product is included on an order that cannot be dispensed at a facility
- The way that a third-party identifies a product has changed
Environment / Applies To
- Terminal Management 2
- Terminal Management TMX
- Interfaces with third-party ERP/accounting/agronomy systems
Solution Summary
If an interface tries to import an order that includes an unrecognized product identifier, the import will fail (the order will not be available in Terminal Management) and in most cases a message is written to the event log:
Exception encountered while updating order [order number]: No product information found for [product identifier] - Interface ID: [product identifier]
A cross-reference must be set up for each product that a third-party system might include in an order so that the interface can relate the product identifier used by the third-party system to a product that exists in Terminal Management.
Note: It might not always be clear which product that the product identifier (specified by third-party system) refers to. You may need to reference the third-party system to determine what product the product identifier refers to.
Solution In-Depth
Note: The following instructions require that you login to Terminal Management as a user with either the "view/modify products" user permission or modify access for the "products" user profile permission.
1. In Terminal Management, click on the "Products" section link (on the left side of the page).
2. Click the "Product Setup" tab (if not already selected)
3. Click the "Edit Existing Product" button
Tip: You can reduce the number of products listed by typing all or a part of the product name in the field that contains the text "enter product to search for..."
Note: If the product is not listed it may not exist in Terminal Management or may not be accessible due to ownership (in situations where two or more businesses are operating in a single facility). If the product does not exist, it can be created by clicking the "Create New Product" button instead of the "Edit Existing Product" button.
4. Select the product from the list
5. Click through the prompts until you are asked "will this product be imported or exported using an interface?"
6. Click the "Yes" button
Note: There may be more than one interface setup in Terminal Management. A separate cross-reference may be setup for a product for each interface. Make sure that you are adding the cross-reference for the correct interface.
7. Under the interface that tried to import the order, click the "+" button, next to the "Cross Reference" text
8. Enter the product identifier (or "interface ID") that was included in the error message reported in Terminal Management's event log
Note: You may be prompted to enter an "interface exchange unit". This is the unit of measure that the third-party system uses when specifying request quantities and reading dispensed quantities.
Note: You may be prompted to enter an "order item unit". This is the unit of measure that will be used to specify a request quantity on an order. If this is different than the unit of measure that the third-party uses to specify the request quantity, the interface will attempt to convert the quantity to this unit of measure.
9. Click the "Add" button
The cross-reference will now appear under the interface.
10. Click the "Next" button
11. Click through any additional prompts and at the summary screen click the "Save" button
The interface should now be able to import orders with the product included.
Note: The process for reimporting an order varies for each third-party system. Some will automatically try to import the order again while others may require manual intervention (reissuing the order in the third-party system or some kind of file manipulation).
Still Need Help?
Submit an online web ticket or call us at Kahler Automation 507-235-6648 Option 2.