Many Kahler Automation applications are equipped with the ability to check for and download updates. Occasionally the update process can be disrupted or blocked.
Common Causes
- Stranded update process running
- Access to web server that hosts update files blocked by computer/network security
- Insufficient user privileges
Environment / Applies To
- Subscription-licensed software
Solution In-Depth
Note: This article suggests actions that may require an IT professional.
Stranded update process running
If an update was previously attempted but failed it is possible that an instance of the software used to perform the update is still active, but stranded.
The Windows Task Manager app can be used to determine if an instance of the update process is running and end it if it is.
To start the Task Manager app, right-click on the Windows task bar and select "Task Manager".
In the Task Manager window, click the "Processes" tab.
Look for an app/process named "wyUpdate" in the list.
Tip: Sorting the list of processes by name may make it easier to find the process. To sort processes by name, click the "Name" column header.
Select the "wyUpdate" app/process and click the "End task" button.
After ending any instances of the "wyUpdate" app/process, try updating the software again.
Note: Older versions of web-based applications allowed updates to be initiated from a page in the application. This functionality has been removed in favor of initiating the update from the server computer used to host the web-application (either through an update shortcut on the Start Menu or by running the wyUpdate.exe program located in the application installation directory). Initiating an update through a page in the application was a common cause of a stranded update process.
Access to update files blocked by computer/network security
Software updates are downloaded from the internet. Computer/network security systems can block access to the site that updates are downloaded from.
Ensure that any computer/network security systems allow the computer to download files from the following URLs:
- https://licensing.kahlerautomation.com/Updates
- http://licensing.kahlerautomation.com/Updates
- ftp://licensing.kahlerautomation.com/Updates
Applications use these three URLs, in the specified order.
Note: The full URL for application-specific updates may be deeper than the URLs listed above (e.g., http://licensing.kahlerautomation.com/Updates/TerminalManagement2/Release/).
Insufficient user privileges
The Windows user that is used to initiate the software update must have write access to the directory where the application is installed.
Still Need Help?
Submit an online web ticket or call us at Kahler Automation 507-235-6648 Option 2.