Problem communicating with remote licensing/application service

Applications with subscription licenses need to communicate with a licensing/application service to update license information.

Common Causes

  • Internet connectivity unavailable
  • Connection to licensing/application service blocked by security system

Environment / Applies To

  • All subscription licensed applications
  • Terminal Management TMX
  • Interfaces with 3rd party ERP/accounting/agronomy packages
  • Plant Supervisor PSX
  • Self-Serve 2
  • KA-2025 Panel Server
  • Truck Scale Management
  • Bulk Receiving Terminal 2

Solution Summary

Subscription licensed applications regularly communicate with a licensing/application service to update license information, including license expiration dates (e.g., when a license is renewed) and license capabilities (i.e., modules).

If an application is unable to communicate with the licensing/application service for an extended period of time, it is possible that the application may indicate that the license has expired prematurely.

Solution In-Depth

Note: If an application is unable to communicate with the licensing/application service, it may log the problem in Terminal Management's event log with a message similar to this:

"There was a problem communicating with the remote licensing/application service. Please verify that you can access the licensing/application service from a web browser on the computer that is running this application."

To verify that a computer can access the license/application service, open a web browser on the computer and navigate to the license/application service management portal (http://public.kahlerautomation.com/Licensing).

If the computer has access to the license/application service you should see a login page similar to this:

Screen Shot 2021-03-04 at 2.37.29 PM

If you see anything other than this login page then the computer is not able to access the license/application service and any Kahler Automation applications installed on the computer will also not be able to communicate with the license/application service.

Tip: It is possible that an internet security system is preventing access to the Kahler Automation license/application service. Your company's IT may need to add http://public.kahlerautomation.com/Licensing to its list of sites that may be accessed from company computers.

Still Need Help?

Submit an online web ticket or call us at Kahler Automation 507-235-6648 Option 2.