An interface with Agvance will fail if it is not run as a user with sufficient access permissions for the file paths used to exchange order and ticket files.
Last Updated: 4/2/2021
Common Causes
- The Agvance interface is configured to run as a user that does not have sufficient access permission to access the file paths used to exchange order and ticket files
Environment / Applies To
- Agvance Interface
Solution Summary
The interface must run as a user that has sufficient access permissions (read and write) for the file paths used to exchange order and ticket files.
Solution In-Depth
Order and Ticket File Paths
Note: The following instructions require a login for Terminal Management with either the "view/modify interfaces" user permission or assignment to a user profile with modify access for "interfaces".
In Terminal Management, navigate to the Agvance interface configuration page (typically listed as a tab titled "Agvance" under the "Interfaces" section in Terminal Management).
The Agvance interface supports two modes of operation: "Legacy" and "XML"
- For "Legacy" operation, make note of the "Log Path" and "Import Order Path"
- For "XML" operation, make note of the "Log Path", "Orders Path" and "Export folder path for completed tickets" and the "Archive folder"
These are the file paths that the interface must have read and write access to function correctly.
Tip: If files are exchanged using a file share located on another computer/server, file paths that use mapped drives (e.g., X:\somepath\) may not work since the mapped drive may not be available to the user that the interface runs as or when the interface is run as a scheduled task.
When possible, use the universal naming convention (UNC) path (e.g., \\someserver\somepath\) to specify a file path for a file share.
Scheduled Task Properties
Note: The following instructions require an administrator Windows login for the computer that runs the Kahler Automation interface software, and may also require an IT professional to verify or change user or file permissions.
The Kahler Automation interface software is typically executed using Windows' Task Scheduler. The task must be configured to run as a user that has read and write access permissions for file paths discovered in the Order and Ticket File Paths section of this article.
1. Open Windows Task Scheduler
2. Find the task that is responsible for running the Kahler Automation interface (typically named "Agvance Interface", "Tm2AgvanceInterface" or something similar)
3. Open the properties for the task
4. Determine what user the task runs as (under the "General" tab, listed in the "Security options" group box as "When running the task, use the following user account")
5. Make sure that the user listed has read and write permissions for the file paths discovered in the Order and Ticket File Paths section of this article - if not, either grant read and write access or change the task to run as a user that does have read and write access
Tip: Built-in users like "SYSTEM" and "NETWORK SERVICE" will not work if the file paths point to a file share on a different computer/server.
Still Need Help?
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